Chrome not updating website

Its not my internet, as i have about 25Mbps down and 7 up.Other browsers are working fine, but I prefer Chrome!I've used both for a long time and the issue wasn't cropping up but now it's nearly unusable. I've been a Chrome user for nearly two years, but recently I'm having a big issue.Every time i open the browser it struggles to even open the home page or tabs like the settings.Until there is a reliable fix from Google, I have to relegate the Chrome Browser to the dust heap of history. I'm very experienced technically and this one has me baffled. This started a week or two ago, perhaps with an update.

I've also found Chrome really slow for about the last 3 weeks.

I don't know what is wrong, but I am having the same problem. I disabled hardware accelleration and it didn't make a noticable difference for me.

I've tried everything, deleting unused and unwanted programs from my computer, cutting down on extensions and plug-ins, etc. Running Malwarebytes has measurably improved the address bar lag.

Worlds biggest company screws up mass usage portal. Chrome is really really really really SLOW for the last 15-20 days in my Windows 10 Tech Preview (desktop mode). So, I feel Chrome has some serious issue with Win 10 Tech Preview side.

I've 50Mbps always from comcast, still youtube is slow, netflix is slow (though it works fine in my xbox one), even google maps is slow, daily motion is slow. i've checked for anti virus none, checked unwanted plugins none, no extn running in chrome. As suggested, I've uninstalled Bit Defender and disabled H/W acceleration, will post an update how it works after these 2 changes.

Leave a Reply